Minor Bug in Subscription Discount Codes
Incident Report for Conjured
Resolved
We have just pushed a fix that will ensure that the discount value is taken from the highest priced subscription in the cart so the full amount of the discount can be used.
Posted Oct 17, 2019 - 11:07 MDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 28, 2019 - 11:03 MDT
Update
We have pushed a fix for the issue of orders being created in Shopify with the incorrect value for the line item in the order (#2). Still working on a fix for the customer not being discounted the full amount of the discount code when charged (#1).
Posted Sep 28, 2019 - 11:03 MDT
Identified
We have identified a bug in the way discount codes are handled for subscriptions when the following conditions are true:

a. The discount code applies to an order containing "Any Subscription Box",
b. The customer orders more than one subscription during checkout, and
c. The value of the discount is greater than the value of the first subscription box added to the cart.

In this case, the first subscription box is discounted 100% (since it costs less than the value of the discount), but the remainder of the discount amount isn't applied to the rest of the cart. This causes two problems:

1. The customer is not being discounted the full amount of the discount code when charged, and
2. The order created in Shopify has an incorrect value for the line items in the order.

We are currently in the process of patching this bug and will update here when a fix is live.
Posted Sep 28, 2019 - 09:19 MDT
This incident affected: Conjured Subscriptions - Customer-Facing.